VARGROUP

inspiring innovation

API FATTURE PA & B2B
Rel. 3.3.2

Ogni attivazione ha tre elementi distintivi e univoci :
1- Utente

2- password

3- id ambiente

Ogni singola attivazione ha uno spazio FTP proprietario e riservato, accessibile tramite
utente e password dell’attivazione.

Ogni singola attivazione ha una serie di APl webservices, accessibili tramite utente e
password dell'attivazione.

CARATTERISTICHE GENERALI TRASMISSIONE DOCUMENTI

Ogni trasmissione alla piattaforma deve essere effettuata tramite un pacchetto di
versamento (PdV) che consiste in un file ZIP contenente i files XML da inviare (fatture o
esiti) e un indice del pacchetto di versamento (IPdV) contenente i metadati dei suddetti
files.

Ogni PdV deve contenere un unico IPdV.

L'indice del pacchetto di versamento (IPdV) € un file XML con la struttura definita in
allegato 1.

L'indice  del pacchetto di versamento (IPdV) deve essere nominato
submission_index_ XXXXXXXXXXxXX.xml, dove XXXXXXXXXXxX deve essere un qualsiasi valore
che renda univoco il nome file (per esempio YYYYMMDDHHiiSSmmm).

Il file ZIP del PdV deve essere nominato submission_pack XXXXXXXXXXXX.zip, dove
XXXXXXXXXXXX deve essere un qualsiasi valore che renda univoco il nome file (per esempio
YYYYMMDDHHiiSSmmm).

Tutti i nomi files devono comprendere solo lettere e numeri del set basso della tabella ascii
(da 48 a 57 e da 97 a 122), non devono contenere spazi, possono contenere punti, trattini
e underscore.

Tutti i nomi file devono essere minuscoli.
| singoli files da inviare e i singoli files IPdV non devono superare la dimensione di 4mb.
Il file PAV ZIP non deve superare la dimensione di 10mb

Una volta elaborati tutti i PdV verranno eliminati.
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CARATTERISTICHE GENERALI RAPPORTO DI VERSAMENTO

Una volta elaborato il PdV la piattaforma genera un rapporto di versamento (RdV) con lo
stesso tracciato del file indice del pacchetto di versamento (IPdV) con valorizzate delle
variabili all'interno dell’XML che identificato la presa in carico o lo scarto dei documenti
versati.

I files di rapporto di versamento (RAV) sono nominati
report_submission_index_XxxXxxxxxxxxx.xml con riferimento al PdV .

CARATTERISTICHE GENERALI PACCHETTO ESITO / FATTURE ACQUISTO DALLO
SDI

La piattaforma genera automaticamente un pacchetto di esito (PdE) in formato ZIP
composto da un file indice in cui vengono riportati i metadati a cui si riferiscono gli esiti
stessi o le fatture di acquisto (esempio id documento inviato e rif. Gestionale) e i files XML
degli esiti / fatture di acquisto provenienti dallo SDI.

In caso le fatture di acquisto provenienti dallo SDI siano firmate nel formato CAJdES-BES
(estensione .p7m) la piattaforma include nel pacchetto di esito i documenti non firmati, per
facilitare I'elaborazione da parte dellERP.

Il file ZIP del PAE & nominato result_pack XXXXXXXXXXXX.Zip.

Il file indice &€ un XML con la struttura definita in allegato 2 ed €& nominato
result_index_ XXXXXXXXxxxx.xml.

| files, una volta prelevati, devono essere eliminati dal Partner. In ogni caso verranno
eliminati dalla piattaforma dopo 6 mesi dalla data di creazione.
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GESTIONE TRAMITE FTP

La struttura dello spazio FTP riservato e la seguente :
/send/fe

Ireceivelfe
/pdv_result
/sdi_result

TRASMISSIONE DOCUMENTI ALLA PIATTAFORMA
Il pacchetto di versamento (PdV) deve essere depositato nella cartella FTP /send/fe/.
(submission_pack XXXXXXXXXXXX.ZIp)

RAPPORTO DI VERSAMENTO
Nella cartella /receive/fe/pdv_result la piattaforma inserisce i risultati della trasmissione
PdV sotto forma di rapporto di versamento. (report_submission_index_ XXXXXXXXXXXX.xml)

PACCHETTO ESITO DALLO SDI
Nella cartella /receivel/fe/sdi_result la piattaforma inserisce i pacchetti di esito ZIP
provenienti dallo SDI. (result_pack_XXXXXXXXXXXX.zip)

GESTIONE TRAMITE WEBSERVICES

La piattaforma prevede la gestione tramite interfacce webservices con protocollo SOAP.
L'endpoint sia per I'invio che per la ricezione é : http://url_server_api/api_fe.php

TRASMISSIONE DOCUMENTI ALLA PIATTAFORMA

Metodo : submissionPackRequest

Input :

user = Codice utente ;

password = Password utente codificata in MD5;
environment = Codice Ambiente;

filesize_pdv = Dimensione del file PdV formato ZIP;
filename_pdv = Nome del file PdV formato ZIP;
hash_pdv = Hash 256 del file PdV formato ZIP;
base64 pdv = Contenuto del file PdV in BASE64 ;

Output :

status = Stato Return code dell’'upload. Possibili Valori : 00 - OK /99 - KO ;
error_code = Numero Errore Return Code ;

error_desc = Descrizione dell’eventuale errore ;
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RAPPORTO DI VERSAMENTO

Metodo : reportSubmissionList

Input :

user = Codice utente ;

password = Password utente codificata in MD5;
environment = Codice Ambiente;

Output :

status = Stato Return code. Possibili Valori : 00 - OK /99 - KO ;
error_code = Numero Errore Return Code ;

error_desc = Descrizione dell’eventuale errore ;

Array contenente la lista dei rapporti di versamento, cosi composto :
filename_rdv = Nome del file RdV;

date_rdv = data e ora del file RdV;

Metodo : reportSubmissionRequest

Input :

user = Codice utente ;

password = Password utente codificata in MD5;
environment = Codice Ambiente;

filename_rdv = Nome del file RdV;

Output :

status = Stato Return code. Possibili Valori : 00 - OK /99 - KO ;
error_code = Numero Errore Return Code ;

error_desc = Descrizione dell’eventuale errore ;

Array contenente i dati del rapporto di versamento, cosi composto :
filesize_rdv = Dimensione del file RdV ;

filename_rdv = Nome del file RdV ;

hash_rdv = Hash 256 del file RdV ;

base64 rdv = Contenuto del file RdV in BASE64 ;

Metodo : reportSubmissionDelete

Input :

user = Codice utente ;

password = Password utente codificata in MD5;
environment = Codice Ambiente;

filename_rdv = Nome del file RdV da eliminare;

Output :

status = Stato Return code. Possibili Valori : 00 - OK /99 - KO ;
error_code = Numero Errore Return Code ;

error_desc = Descrizione dell’eventuale errore ;
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PACCHETTO ESITO / FATTURE ACQUISTO DALLO SDI

Metodo : resultPackList

Input :

user = Codice utente ;

password = Password utente codificata in MD5;
environment = Codice Ambiente;

Output :

status = Stato Return code. Possibili Valori : 00 - OK /99 - KO ;

error_code = Numero Errore Return Code ;

error_desc = Descrizione dell’eventuale errore ;

Array contenente la lista dei pacchetti di Esito / fatture di acquisto, cosi composto :
filename_pde = Nome del file PdE;

date pde = data e ora del file PdE;

Metodo : resultPackRequest

Input :

user = Codice utente ;

password = Password utente codificata in MD5;
environment = Codice Ambiente;

filename_pde = Nome del file PdE;

Output :

status = Stato Return code. Possibili Valori : 00 - OK /99 - KO ;
error_code = Numero Errore Return Code ;

error_desc = Descrizione dell’eventuale errore ;

Array contenente i dati del rapporto di versamento, cosi composto :
filesize_pde = Dimensione del file PdE ;

filename_pde = Nome del file PdE ;

hash_pde = Hash 256 del file PdE ;

base64 pde = Contenuto del file PdE in BASE64 ;

Metodo : resultPackDelete

Input :

user = Codice utente ;

password = Password utente codificata in MD5;
environment = Codice Ambiente;

filename_pde = Nome del file PdE da eliminare;

Output :

status = Stato Return code. Possibili Valori : 00 - OK /99 - KO ;
error_code = Numero Errore Return Code ;

error_desc = Descrizione dell’eventuale errore ;
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Allegato 1 : Struttura indice del pacchetto di versamento (IPdV)
<?xml version="1.0" encoding="utf-8"?>
<PdV version="3.3.2">
<SelfDescription>
<ID>Id univoco del PdV (OBBLIGATORIO)</ID>
<CreatingApplication>
<Name>Nome dell’applicazione che ha generato il PdV (OBBLIGATORIO)</Name>
<Version>Versione dell'applicazione che ha generato il PdV (OBBLIGATORIO)</Version>
<Producer><![CDATA[Denominazione dell’azienda che ha prodotto I'applicazione per la generazione del PdV
(OBBLIGATORIO)]]></Producer>
</CreatingApplication>
<SourceldV>
<ID>Id univoco del PdV precedente o Id del PdV relazionato</ID>
<Path><![CDATA[Nome del file PdV precedente o nome del PdV relazionato]]></Path>
<Hash>
<Type>SHA-256</Type>
<Value><![CDATA[Hash del PdV precedente o hash del PdV relazionato]]></Value>
</Hash>
</SourceldV>
<Morelnfo>
<PdVType><![CDATA[SUBFE]]></PdVType>
<DataOwner>
<Name><![CDATA[Denominazione dell'azienda alla quale si riferiscono i documenti (titolare) (OBBLIGATORIO)]]>
</Name>
<FiscalCode>Codice fiscale dell'azienda alla quale si riferiscono i documenti (titolare) (OBBLIGATORIO)</FiscalCode>
<VatNumber>Partita IVA dell'azienda alla quale si riferiscono i documenti (titolare) (OBBLIGATORIO)</VatNumber>
<ldCompany>Codice Ambiente di attivazione assegnato (OBBLIGATORIO)</IdCompany>
</DataOwner>
<PdvProducer>
<Name><![CDATA[Denominazione dell’'azienda che ha generato il PdV ed effettua il versamento
(OBBLIGATORIO)[]></Name>
<FiscalCode>Codice fiscale dell'azienda che ha generato il PdV ed effettua il versamento (OBBLIGATORIO)</FiscalCode>
<VatNumber>Partita IVA dell’'azienda che ha generato il PdV ed effettua il versamento (OBBLIGATORIO)</VatNumber>
</PdvProducer>
</Morelnfo>
</SelfDescription>
<vdv>
<ID>Id univoco del PdV (OBBLIGATORIO)</ID>
<VdVGroup>
<ID>Codice della tipologia documentale, alla quale appartengono i documenti presenti nel pacchetto (OBBLIGATORIO SE
NOPN SPECIFICATO IN filegroup)</ID>
<Label><![CDATA[Nome della tipologia documentale, alla quale appartengono i documenti presenti nel pacchetto (ad es.
Fatture attive)]]></Label>
<Description><![CDATA[Descrizione della tipologia documentale, alla quale appartengono i documenti presenti nel
pacchetto (ad es. FATTURE ATTIVE)]]></Description>
</VdVGroup>
<Morelnfo>
<Result>
<TimeReference>
<Timelnfo>2018-01-01T10:06:01+02:00</Timelnfo>
</TimeReference>
<ReturnCode>Codice di ritorno dell'intera elaborazione del PDV. Valori = 00->0K; 99->SCARTATO; 10->OK CON
WARN</ReturnCode>
<ReturnString><![CDATA[Descrizione globale dell'elaborazione]]></ReturnString>
<ReturnErr><!/[CDATA[Descrizione degli errori e warnings]]></ReturnErr>
<Returnld>Id univoco del PdV assegnato dalla piattaforma</Returnld>
</Result>
</Morelnfo>
</vdv>
<FileGroup>
<File>
<Path><I[CDATA[Nome del file contenuto all'interno del pacchetto (OBBLIGATORIO)]]></Path>
<Hash>
<Type>SHA-256</Type>
<Value><![CDATA[Hash del file (OBBLIGATORIO)]]></Value>

</Hash>
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<Morelnfo>
<Function>Funzione sul singolo attach. Valori : I=inserisci C=Cancella S=Sostituisci</Function>
<Attachld>Id univico dell'attach all'interno dellERP</Attachld>
<AttachType>Codice della tipologia di allegato (es. XNS=Notifica di scarto) (OBBLIGATORIO)</AttachType>
<MimeType>Mime type che definisce il tipo di file, standard IANA (es. application/xml) (OBBLIGATORIO)</MimeType>
<Signed>Flag Signed = true documento firmato ; false = Documento NON firmato (OBBLIGATORIO)</Signed>
<Send>Flag Send = true documento da inviare ; false = Documento NON da inviare (OBBLIGATORIO)</Send>
<Result>
<TimeReference>
<Timelnfo>2018-01-01T10:06:01+02:00</Timelnfo>
</TimeReference>
<ReturnCode>Codice di ritorno dell'elaborazione del singolo attach. Valori = 00->0K; 99->SCARTATO; 10->OK CON
WARN</ReturnCode>
<ReturnString><![CDATA[Descrizione globale dell'elaborazione]]></ReturnString>
<ReturnErr><![CDATA[Descrizione degli errori e warnings]]></ReturnErr>
<Returnld>Id univoco del singolo attach assegnato dalla piattaforma</Returnid>
</Result>
</Morelnfo>
</File>
<File>
Segue elenco di tutti i files con la stessa struttura sopra riportata
</File>
<Morelnfo>
<ID>Id univico del documento all'interno del’ERP (rif. Gestionale) (OBBLIGATORIO)</ID>
<DocType>Codice della tipologia documentale alla quale appartiene il documento (OBBLIGATORIO)</DocType>
<ExerciseDate>Data fine esercizio di competenza del documento (OBBLIGATORIO)</ExerciseDate>
<Function>Funzione. Valori : I=inserisci C=Cancella S=Sostituisci A=Allega (OBBLIGATORIO)</Function>
<Result>
<TimeReference>
<Timelnfo>2018-01-01T10:06:01+02:00</Timelnfo>
</TimeReference>
<ReturnCode>Codice di ritorno dell'elaborazione del documento. Valori = 00->0K; 99->SCARTATO; 10->OK CON
WARN</ReturnCode>
<ReturnString><![CDATA[Descrizione globale dell'elaborazione]]></ReturnString>
<ReturnErr><![CDATA[Descrizione degli errori e warnings]]></ReturnErr>
<Returnld>ld univoco del documento assegnato dalla piattaforma</Returnld>
</Result>
<MetaData> (SE NON SPECIFICATI METADATI | DATI VENGONO RICAVATI DAL FILE XML DELLA FATTURA)
<Index>
<Name><![CDATA[Chiave del metadato (es. key_02]]></Name>
<DescName><![CDATA[Descrizione del metadato (es. Data Documento]]></DescName>
<Value><![CDATA[Valore assegnato al metadato (ad es. 2018-01-01]]></Value>
<Required><![CDATA[true / false]]></Required>
<Type><![CDATA[string / date / numeric ]]></Type>
</Index>
<Index>
Segue elenco di tutti i metadati definiti con la stessa struttura sopra riportata
</Index>
</MetaData>
</Morelnfo>
</FileGroup>
<FileGroup>
Segue elenco di tutti i documenti con la stessa struttura sopra riportata
</FileGroup>
<Process>
<TimeReference>
<Timelnfo>Date e ora della sottoscrizione del PdV : 2018-01-01T10:06:01+02:00 (OBBLIGATORIO)</Timelnfo>
</TimeReference>
<Morelnfo>
<IpSource>IP che ha sottoscritto il PdV (OBBLIGATORIO)</IpSource>
</Morelnfo>

</Process>
</PdV>
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Allegato 2 : Struttura Indice del pacchetto di esito (IPdE)
<?xml version="1.0" encoding="utf-8"?>
<PdE version="3.3.2">
<SelfDescription>
<|D>Id univoco del PdE</ID>
<CreatingApplication>
<Name>Nome dell’applicazione che ha generato il PAE</Name>
<Version>Versione dell’'applicazione che ha generato il PdE</Version>
<Producer><![CDATA[Denominazione dell'azienda che ha prodotto I'applicazione per la generazione del PdE]]></Producer>
</CreatingApplication>
<SourceldE>
<ID>Id univoco del PdE precedente o Id del PdE relazionato</ID>
<Path><![CDATA[Nome del file PdE precedente o nome del PdE relazionato]]></Path>
<Hash>
<Type>SHA-256</Type>
<Value><![CDATA[Hash del PdE precedente o hash del PdE relazionato]]></Value>
</Hash>
</SourceldE>
<Morelnfo>
<PdEType><![CDATA[SUBFEPDE]]></PdEType>
<DataOwner>
<Name><![CDATA[Denominazione dell’'azienda alla quale si riferiscono i documenti (titolare)]]> </Name>
<FiscalCode>Codice fiscale dell'azienda alla quale si riferiscono i documenti (titolare)</FiscalCode>
<VatNumber>Partita IVA dell'azienda alla quale si riferiscono i documenti (titolare)</VatNumber>
<ldCompany>Codice Ambiente di attivazione assegnato</l[dCompany>
</DataOwner>
<PdvProducer>
<Name><![CDATA[Denominazione dell'azienda che ha generato il PdE ed effettua il versamento]]></Name>
<FiscalCode>Codice fiscale dell'azienda che ha generato il PdE ed effettua il versamento</FiscalCode>
<VatNumber>Partita IVA dell'azienda che ha generato il PdE ed effettua il versamento</VatNumber>
</PdvProducer>
</Morelnfo>
</SelfDescription>
<FileGroup>
<File>
<Path><![CDATA[Nome del file contenuto all'interno del pacchetto]]></Path>
<Hash>
<Type>SHA-256</Type>
<Value><![CDATA[Hash del file]]></Value>
</Hash>
<Morelnfo>
<Attachld>Id univico dell'attach all'interno del’lERP</Attachld>
<AttachType>Codice della tipologia di allegato (es. XNS=Notifica di scarto)</AttachType>
<MimeType>Mime type che definisce il tipo di file, standard IANA (es. application/xml)</MimeType>
</Morelnfo>
</File>
<File>
Segue elenco di tutti i files con la stessa struttura sopra riportata
</File>
<Morelnfo>
<ID>Id univico del documento all'interno del’ERP (rif. Gestionale)</ID>
<DocType>Codice della tipologia documentale alla quale appartiene il documento</DocType>
<MetaData>
<Index>
<Name><I[CDATA[Chiave del metadato (es. key_02]]></Name>
<DescName><![CDATA[Descrizione del metadato (es. Data Documento]]></DescName>
<Value><![CDATA[Valore assegnato al metadato (ad es. 2018-01-01]]></Value>
<Required><![CDATA[true / false]]></Required>
<Type><![CDATA|[string / date / numeric []></Type>
</Index>
<Index>
Segue elenco di tutti i metadati definiti con la stessa struttura sopra riportata
</Index>
</MetaData>
</Morelnfo>
</FileGroup>
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<FileGroup>
Segue elenco di tutti i documenti con la stessa struttura sopra riportata
</FileGroup>
<Process>
<TimeReference>
<Timelnfo>Date e ora della sottoscrizione del PdE : 2018-01-01T10:06:01+02:00</Timelnfo>
</TimeReference>
<Morelnfo>
<IpSource>IP che ha sottoscritto il PAE</IpSource>
</Morelnfo>

</Process>
</PdE>
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